Repeating |

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RepeatingReferenceSource type exposes the following members.

Name | Description | |
---|---|---|
![]() | DimensionCount | The dimension count of the repeating reference array. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the RepeatingReferenceSource |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetBounds | Returns information about the boundaries of the repeating reference array. |
![]() ![]() | GetDefaultRepeatingReferenceSource | Returns the default repeating reference source for a given element. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetReference | Returns an individual repeating reference given by coordinates in the array, or if there is no reference at the coordinates (for example if there is a hole in a divided surface.) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() ![]() | HasRepeatingReferenceSource | Determines whether an element has any repeating reference sources that can be used when creating component repeaters. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The RepeatingReferenceSource class is the building block for setting up component repeaters. Repeating references are arranged in zero, one or two dimensional arrays. The RepeatingReferenceSource class represents this array of references and provides access to individual repeating references.
Note that there may be gaps in the array (for example a repeating reference source formed by a divided surface with holes, or is non-rectangular surface.)
Repeating reference sources are a property of an element. Only point elements, divided paths and divided surface elements support repeating reference sources. These element respectively have 0, 1 and 2 dimensional repeating references. Use the HasRepeatingReferenceSource() method to query whether an element supports repeating reference sources and the GetDefaultRepeatingReferenceSource() method to obtain a repeating reference source from a given element.
See the ComponentRepeater and ComponentRepeaterSlot classes for more information.