FindDefinitionType Method


Direct Shape Library Find Definition Type Method

Find a DirectShapeType element by definition id. The element will be used for creating instances of that definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId FindDefinitionType(
	string id
)

Parameters

id String
Definition id. Expected to be unique.

Return Value

ElementId
Element id of a DirectShapeTypeElement
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also