GetParameterValue Method


Subelement Get Parameter Value Method

Obtains the current parameter value of this subelement given a parameter id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ParameterValue GetParameterValue(
	ElementId parameterId
)

Parameters

parameterId ElementId
Parameter id.

Return Value

ParameterValue
Parameter value.
Exceptions
Exception Condition
ArgumentException parameterId does not identify a valid parameter of this subelement.
ArgumentNullException A non-optional argument was null
See Also