SetFromCurves Method


Rebar Container Item Set From Curves Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetFromCurves(
	RebarStyle style,
	RebarBarType barType,
	RebarHookType startHook,
	RebarHookType endHook,
	XYZ norm,
	IList<Curve> curves,
	RebarHookOrientation startHookOrient,
	RebarHookOrientation endHookOrient,
	bool useExistingShapeIfPossible,
	bool createNewShape
)

Parameters

style RebarStyle
barType RebarBarType
startHook RebarHookType
endHook RebarHookType
norm XYZ
curves IList Curve
startHookOrient RebarHookOrientation
endHookOrient RebarHookOrientation
useExistingShapeIfPossible Boolean
createNewShape Boolean
See Also