LeftAnnotationCropOffset Property


View Crop Region Shape Manager Left Annotation Crop Offset Property

The offset from the left of the view crop that determines the location of the annotation crop left boundary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double LeftAnnotationCropOffset { get; set; }

Property Value

Double
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: The given value for offset must be non-negative.
InvalidOperationException View is not allowed to have an annotation crop.
Remarks
This value must be a non-negative length in view units. Default value is 1/12' (1"), minimal value is 1/96' (1/8"). To get offset in model units, multiply the value by the view scale.
See Also