PreScale Method


Transform 2D Pre Scale Method

Scales the linear part of this transformation and returns the result.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Transform2D PreScale(
	double scale
)

Parameters

scale Double
The scale value.

Return Value

Transform2D
Returns a pointer to "this" Transform2D .
Remarks
The resulting transformation is equivalent to the application of the uniform scale and then this transformation, in this order.
See Also