GenericZoneDomainData Class


Generic Zone Domain Data Class

A base class for specific domain requirements for a generic zone.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis GenericZoneDomainData
Autodesk.Revit.DB.Mechanical SystemZoneData

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class GenericZoneDomainData : IDisposable

The GenericZoneDomainData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the GenericZoneDomainData
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also