ImageExportOptions Class


Image Export Options Class

This class defines options for exporting views and sheets as an image.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ImageExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ImageExportOptions : IDisposable

The ImageExportOptions type exposes the following members.

Constructors
Name Description
Public method ImageExportOptions Constructs a new instance of the options class used to produce images.
Top
Properties
Name Description
Public property ExportRange The export range defining which view(s) will be exported.
Public property FilePath The file name and path for the exported file.
Public property FitDirection The fit direction. Used only if ZoomType is FitToPage.
Public property HLRandWFViewsFileType File type for exported HLR and wireframe views.
Public property ImageResolution The image resolution in dots per inch.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property PixelSize The pixel size of an image in one direction. Used only if ZoomType is FitToPage.
Public property ShadowViewsFileType The file type for exported shadow views.
Public property ShouldCreateWebSite Whether or not to create a web site with a page for each export. Used only when ExportRange is SetOfViews.
Public property ViewName The name of the view to be created.
Public property Zoom The value for Zoom (as a percentage). Used only when ZoomType is Zoom.
Public property ZoomType The zoom type, which defines how the image size is determined.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ImageExportOptions
Public method Static member GetFileName Gets the file name that will be produced when exporting a view to an image.
Public method GetViewsAndSheets Gets a list of views and sheets to be exported. Used only when ExportRange is SetOfViews.
Public method Static member IsValidFileName Verify if File name is valid
Public method Static member IsValidForSaveToProjectAsImage Verify if ImageExportOptions object is valid for calling saveToProjectAsImage
Public method SetViewsAndSheets
Top
See Also