XYZ Class


XYZ Class

Object representing coordinates in 3-dimensional space.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB XYZ

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class XYZ

The XYZ type exposes the following members.

Constructors
Name Description
Public method XYZ Creates a default XYZ with the values (0, 0, 0).
Public method XYZ(Double, Double, Double) Creates an XYZ with the supplied coordinates.
Top
Properties
Name Description
Public property Static member BasisX The basis of the X axis.
Public property Static member BasisY The basis of the Y axis.
Public property Static member BasisZ The basis of the Z axis.
Public property Item Indexed access to coordinates.
Public property X Gets the first coordinate.
Public property Y Gets the second coordinate.
Public property Z Gets the third coordinate.
Public property Static member Zero The coordinate origin or zero vector.
Top
Methods
Name Description
Public method Add Adds the specified vector to this vector and returns the result.
Public method AngleOnPlaneTo Returns the angle between this vector and the specified vector projected to the specified plane.
Public method AngleTo Returns the angle between this vector and the specified vector.
Public method CrossProduct The cross product of this vector and the specified vector.
Public method DistanceTo Returns the distance from this point to the specified point.
Public method Divide Divides this vector by the specified value and returns the result.
Public method DotProduct The dot product of this vector and the specified vector.
Public method GetLength Gets the length of this vector.
Public method IsAlmostEqualTo(XYZ) Determines whether this vector and the specified vector are the same within the tolerance (1.0e-09).
Public method IsAlmostEqualTo(XYZ, Double) Determines whether 2 vectors are the same within the given tolerance.
Public method IsUnitLength The boolean value that indicates whether this vector is of unit length.
Public method Static member IsWithinLengthLimits Validates that the input point is within Revit design limits.
Public method IsZeroLength The boolean value that indicates whether this vector is a zero vector.
Public method Multiply Multiplies this vector by the specified value and returns the result.
Public method Negate Negates this vector.
Public method Normalize Returns a new XYZ whose coordinates are the normalized values from this vector.
Public method Subtract Subtracts the specified vector from this vector and returns the result.
Public method ToString Gets formatted string showing (X, Y, Z) with values formatted to 9 decimal places.
(Overrides Object ToString )
Public method TripleProduct The triple product of this vector and the two specified vectors.
Top
Operators
Name Description
Public operator Static member Addition(XYZ, XYZ) Adds the two specified vectors and returns the result.
Public operator Static member Division(XYZ, Double) Divides the specified vector by the specified value.
Public operator Static member Multiply(Double, XYZ) Multiplies the specified number and the specified vector.
Public operator Static member Multiply(XYZ, Double) Multiplies the specified number and the specified vector.
Public operator Static member Subtraction(XYZ, XYZ) Subtracts the two specified vectors and returns the result.
Public operator Static member UnaryNegation(XYZ) Negates the specified vector and returns the result.
Top
Remarks
Usually this means a point or a vector in 3-dimensional space, depending on the actual use.
See Also