BuiltInFailures.FaceSplitterFailures Class


Built In Failures Face Splitter Failures Class

Failures about FaceSplitter.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures FaceSplitterFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class FaceSplitterFailures

The BuiltInFailures FaceSplitterFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotUseCurvesForFaceSplit The sketch cannot split the face of the highlighted element.
Public property Static member EndsNotOnEdgeError Ends of an open loop in sketch splitting face do not lie on an edge of the face to split.
Public property Static member InvalidClosedLoopsForFaceSplit The closed loop used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges. To split a face at its border, use an open loop that ends on the boundary of the face.
Public property Static member InvalidOpenLoopsForFaceSplit The open loops used to split the face must lie completely within the face and cannot intersect or overlap any of the face's edges.
Public property Static member LoopsDoNotSubdivideFace Sketched loops must sub-divide the face into two or more completely enclosed regions.
Public property Static member LoopsOutsideFaceSplitError Some of the lines drawn lie outside of the boundary of the face being split. All lines used to split a face must be contained within the face being split and cannot intersect or overlap any of the boundaries of that face.
Public property Static member NoFaceForSplit The highlighted element no longer contains a face that has been split by highlighted sketch.
Top
See Also