Pinned Property


Element Pinned Property

Identifies if the element has been pinned to prevent changes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Pinned { get; set; }

Property Value

Boolean
Exceptions
Exception Condition
InvalidOperationException When setting this property: Element cannot be pinned or unpinned.
Remarks
An element which is pinned may not be moved, and warnings will be issued when an attempt is made to delete it.
See Also