ExportFontInfo Class


Export Font Info Class

A value used to represent the info stored in an ExportFontTable .
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportFontInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportFontInfo : IDisposable

The ExportFontInfo type exposes the following members.

Constructors
Name Description
Public method ExportFontInfo Constructs a new default ExportFontInfo.
Public method ExportFontInfo(ExportFontInfo) Constructs a new copy of the input ExportFontInfo object.
Public method ExportFontInfo(String) Constructs a new ExportFontInfo using the destination font name as input.
Top
Properties
Name Description
Public property DestinationFontName The destination font name (the name of the font in the exported format).
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExportFontInfo
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also