CADLinkOptions Constructor (Boolean, ElementId)


CADLink Options(Boolean, Element Id) Constructor

Creates a CADLinkOptions object, specifying whether to preserve graphic overrides, and what view to use if the link's view has been deleted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public CADLinkOptions(
	bool preserveOverrides,
	ElementId viewId
)

Parameters

preserveOverrides Boolean
True if Revit should preserve the link's graphic overrides on reload. False otherwise.
viewId ElementId

The id of the view to use as the link's reference view, if the reference view has been deleted. Revit will ignore this value if the reference view is still in place.

The value may be ElementId.InvalidElementId, although Revit will cancel the load if the reference view is deleted.

Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also