SetLightDistributionStyle Method


Light Family Set Light Distribution Style Method

Set the light distribution style to the given shape distribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetLightDistributionStyle(
	LightDistributionStyle lightDistributionStyle
)

Parameters

lightDistributionStyle LightDistributionStyle
The light distribution style to set the light distribution type to
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also