ExporterIFC Class


Exporter IFC Class

The main class provided by Revit to allow implementation of IFC export.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC ExporterIFC

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExporterIFC : IDisposable

The ExporterIFC type exposes the following members.

Properties
Name Description
Public property ExportAs2x2 Obsolete.
Identifies if the file version being exported is IFC2x2.
Public property ExportAs2x3 Obsolete.
Identifies if the file version being exported is IFC2x3.
Public property ExportBaseQuantities Identifies if the export should include IFC standard quantities currently supported by Revit.
Public property FileName The name of the IFC file being exported.
Public property FileVersion Identifies the file version being exported.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SpaceBoundaryLevel Identifies the level of space boundaries being exported.
Public property WallAndColumnSplitting Identifies if division of multi-level walls and columns by levels should take place during this export.
Top
Methods
Name Description
Public method AddBuildingStorey Adds building storey to the exporter's internal cache.
Public method ClearFaceWithElementHandleMap Clear face with element handle map.
Public method Dispose Releases all resources used by the ExporterIFC
Public method FindSpaceBoundingElementHandle Looks up the handle associated to the element and level id from the ExporterIFC's internal cache.
Public method Get2DContextHandle Obsolete.
Obtains the IfcRepresentationContext handle to be used for 2D entities (Annotations).
Public method Get3DContextHandle Obtains the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Public method GetDoorWindowOpeningHandle Get the handle to the opening associated with a hosted (door/window) element from the internal cache.
Public method GetFamilyName Gets the name of the element assigned to the current export state.
Public method GetFile Gets the handle to the IFC file being created during this export operation.
Public method GetHostObjects Returns a collection containing the host object handles in the document.
Public method GetLayerNameForPresentationLayer Get the layer name associated with an element from the default layer mapping table.
Public method GetLevelInfo Returns an object representing the information about a level in the document.
Public method GetLevelInfos Returns a collection containing the information about all levels in the document.
Public method GetMaterialIdForCurrentExportState This gets the material id that is associated with the element in the current export state.
Public method GetOptions Gets the collection of named options set by the exporter client.
Public method GetOrCreateFillPattern Get (or create) the IfcFillPatternStyle associated with an ElementId.
Public method GetPresentationLayerAssignments Get the list of the internally IfcPresentationLayerAssignments and their respective shape representations.
Public method GetRelatedElements Gets all elements not associated to stories.
Public method GetRelatedProducts Gets all products not associated to stories.
Public method PopExportState Resets the internal state of the exporter to process the previously active input element (if any), or the default state if the stack is empty.
Public method PopTransform Resets the internal transform of the exporter to process the previously active input element (if any), or the default transform if the stack is empty.
Public method PushExportState Sets the internal state of the exporter to process the geometry and properties of the input element.
Public method PushTransform Sets the internal transform of the exporter to process the geometry and properties of the input element.
Public method RegisterDoorWindowForUncreatedOpening Registers a door or window in the ExporterIFC's internal cache. The ids registered correspond to openings in walls which have not been processed and created yet.
Public method RegisterFaceWithElementHandle Register face with element handle to make sure the openings created are related to the right element.
Public method RegisterSpaceBoundingElementHandle Stores a handle representing a space bounding element to the ExporterIFC's internal cache.
Public method RemoveBuildingStorey Removes an IFCLevelInfo corresponding to a level from the exporter's internal cache.
Public method Set2DContextHandle Obsolete.
Sets the IfcRepresentationContext handle to be used for 2D entities (Annotations).
Public method Set3DContextHandle Sets the IfcRepresentationContext or IfcRepresentationSubContext handle to be used for 3D entities (Model entities).
Public method SetCurrentExportedDocument Sets the exporter to process a particular document during export.
Public method SetFile Sets the handle to the IFC file being created during this export operation.
Public method SetMaterialIdForCurrentExportState This sets the material id that is to be associated with the element in the current export state.
Public method SetOwnerHistoryHandle Sets the handle to the IfcOwnerHistory for the file.
Top
Remarks
An instance of this class is provided to clients which implement IExporterIFC in order to provide an implementation for IFC export. It contains information on the options selected by the user for the export operation, as well as members used to access specific types of data needed to implement the export properly.
See Also