Adaptive |
Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static IList<ElementId> GetInstanceShapeHandlePointElementRefIds(
FamilyInstance famInst
)
Parameters
- famInst FamilyInstance
- The FamilyInstance
Return Value
IList ElementIdThe Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.

Exception | Condition |
---|---|
ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This operation failed. |

The output contains shape handle point ref ids. If there are no shape handle points defined in the Family then the output is empty.