FamilyPointLocation Class


Family Point Location Class

Data corresponding to the point locations in certain types of Family Symbols.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB FamilyPointLocation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyPointLocation : APIObject

The FamilyPointLocation type exposes the following members.

Properties
Name Description
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The name of the corresponding reference point in the Family document.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetLocation Gets the location of the point.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Examples of FamilySymbol objects that contain placement references are Panels and Flexible Components.
See Also