FamilyPointLocation Class


Family Point Location Class

Data corresponding to the point locations in certain types of Family Symbols.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB FamilyPointLocation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilyPointLocation : APIObject

The FamilyPointLocation type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The name of the corresponding reference point in the Family document.
Top
Methods
Name Description
Public method GetLocation Gets the location of the point.
Top
Remarks
Examples of FamilySymbol objects that contain placement references are Panels and Flexible Components.
See Also