GetFixtureUnits Method


Piping System Get Fixture Units Method

Gets the fixture units of this piping system.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetFixtureUnits()

Return Value

Double
Exceptions
Exception Condition
InvalidOperationException The fixture units can not be calculated for this system.
Remarks
The system fixture units is calculated in the non-blocking evaluation framework. The caller may set up callbacks that react to the asynchronous calculation results. If no callback is set up (e.g, called from third-party applications), the calculation is automatically switched to synchronous calculation so the caller can access the up-to-date result. Similarly, the public method get_ParameterValue(BuiltInParameter.RBS_PIPE_SYSTEM_FIXTURE_UNIT_PARAM) has the same behavior. Due to this change, the parameter RBS_PIPE_SYSTEM_FIXTURE_UNIT_PARAM no longer supports dynamic model update.
See Also