Export(String, String, STEPExportOptions) Method


Document Export(String, String, STEPExport Options) Method

Exports the current view or a selection of views in STEP format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Export(
	string folder,
	string name,
	STEPExportOptions options
)

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
options STEPExportOptions
Various options applicable to the STEP format.

Return Value

Boolean
True if successful, otherwise False.
Exceptions
Exception Condition
ArgumentException NullOrEmpty -or- Contains invalid characters. -or- The provided options do not specify a printable 3D view.
ArgumentNullException A non-optional argument was null
ForbiddenForDynamicUpdateException This method may not be called during dynamic update.
InvalidOperationException Export is temporarily disabled. -or- Exporting is not allowed in the current application mode.
InvalidPathArgumentException The folder does not exist.
OptionalFunctionalityNotAvailableException The ShapeExporter functionality is not available in the installed Revit, or the Material Library is missing.
Remarks
All the views must be 3D views for the Export to succeed.
See Also