Create Method (Document, ThermalAsset)


Property Set Element Create(Document, Thermal Asset) Method

Creates a new PropertySetElement to contain the given asset.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static PropertySetElement Create(
	Document document,
	ThermalAsset thermalAsset
)

Parameters

document Document
The document in which to create the PropertySetElement.
thermalAsset ThermalAsset
The thermal asset containing the values that will be present in the PropertySetElement.

Return Value

PropertySetElement
The new PropertySetElement.
Exceptions
Exception Condition
ArgumentException Thrown when the name of the asset is empty, contains prohibited characters, or is not unique
ArgumentNullException A non-optional argument was null
See Also