Document |
The event arguments used by the DocumentPrinting event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.DB.Events RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events DocumentPrintingEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.DB.Events RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events DocumentPrintingEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The DocumentPrintingEventArgs type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | GetSettings | Gets the print settings of the active printing session. |
![]() | GetViewElementIds | Returns ElementIds of the views to be printed. |