NewReferencePoint Method (PointElementReference)


Family Item Factory New Reference Point(Point Element Reference) Method

Create a reference point on an existing reference in an Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ReferencePoint NewReferencePoint(
	PointElementReference A_0
)

Parameters

A_0 PointElementReference

Return Value

ReferencePoint
The newly created ReferencePoint.
Exceptions
Exception Condition
ArgumentNullException Thrown when the argument is .
InvalidOperationException Thrown when the family is not a Conceptual Mass Family.
Remarks
The location and coordinate system of the point is determined by the particular PointReference subclass, and the point will remain constrained to that reference.
See Also