ExternalDataTypeUpdatedDataSourceIntoDocumentEventArgs Class


External Data Type Updated Data Source Into Document Event Args Class

The event arguments used by the ExternalDataTypeUpdatedInto event.
Inheritance Hierarchy
System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPostEventArgs
Autodesk.Revit.DB.Events RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events ExternalDataTypeUpdatedDataSourceIntoDocumentEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ExternalDataTypeUpdatedDataSourceIntoDocumentEventArgs : RevitAPIPostDocEventArgs

The ExternalDataTypeUpdatedDataSourceIntoDocumentEventArgs type exposes the following members.

Properties
Name Description
Public property ItemId The id of the external data item to which the external data type is updated.
Public property ProjectId The id of the external project of the external data item to which the external data type is updated.
Public property TypeId The type id of the external data type that is being updated.
Top
Methods
Name Description
Top
See Also