DuctSizeSettingIterator Class


Duct Size Setting Iterator Class

An iterator to a set of items from DuctSizeSettings. Each item is a KeyValuePair(DuctShape::Enum, DuctSizes).
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical DuctSizeSettingIterator

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DuctSizeSettingIterator : IEnumerator<KeyValuePair<DuctShape, DuctSizes>>

The DuctSizeSettingIterator type exposes the following members.

Properties
Name Description
Public property Current Gets the item at the current position of the iterator.
Protected property CurrentObject
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DuctSizeSettingIterator
Public method HasCurrent Identifies whether the iterator has a current item. There is no current item if the iterator has not started yet or has been done.
Public method IsDone Identifies if the iteration has completed.
Public method MoveNext Increments the enumerator to the next item.
Public method Reset Resets the iterator to the initial state.
Top
See Also