MEPSpaceConstruction Class


MEPSpace Construction Class

Construction definition for Space.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical MEPSpaceConstruction

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPSpaceConstruction

The MEPSpaceConstruction type exposes the following members.

Properties
Name Description
Public property CurrentConstruction Get all the Building Constructions according to the specific Construction type.
Public property SpaceConstructions Return all the Space constructions of current space.
Top
Methods
Name Description
Public method DeleteConstruction Remove an existing construction from Space constructions.
Public method DuplicateConstruction Create a new construction for Space constructions.
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method NewConstruction Create a new construction for Space constructions.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This is used to define the information in Constructions.xml.
See Also