FabricationItemFile Class


Fabrication Item File Class

This class holds information about the item file, including whether it is already loaded from disk into Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FabricationItemFile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationItemFile : IDisposable

The FabricationItemFile type exposes the following members.

Properties
Name Description
Public property Identifier The string identifier for the item file. This string is unique and can be used to compare whether fabrication item files are the same file.
Public property IsUsed Checks to see if the item file is already in use in the project.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FabricationItemFile
Public method GetImage Gets the image for the fabrication item file.
Public method IsLoaded Checks to see if the item file has been loaded into the configuration.
Public method IsValid Checks to see if the item file is valid.
Top
Remarks
This object is created as a result of loading from disk.
See Also