Spec |
Returns true if the given ForgeTypeId identifies a valid parameter data type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- dataType ForgeTypeId
- The identifier to check.
Return Value
BooleanTrue if the ForgeTypeId identifies either a spec or a category, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

A ForgeTypeId is acceptable as a parameter data type if it identifies either a spec or a category. When a category identifier is used as a parameter data type, it indicates a Family Type parameter of that category.