NewSpace Method (Level, Phase, UV)


Document New Space(Level, Phase, UV) Method

Creates a new space element on the given level, at the given location, and assigned to the given phase.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Space NewSpace(
	Level level,
	Phase phase,
	UV point
)

Parameters

level Level
The level on which the room is to exist.
phase Phase
The phase in which the room is to exist.
point UV
A 2D point that dictates the location on that specified level.

Return Value

Space
If successful a new Space element within the project, otherwise .
Exceptions
Exception Condition
ArgumentNullException Thrown when level, phase or point is .
InvalidOperationException Thrown when the space cannot be created.
ArgumentException Thrown if the level does not exist in the given document.
ArgumentException Thrown if the phase does not exist in the given document.
See Also