Analytical |
Splits the analytical member at a point on its defining curve.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- parameter Double
- The normalized parameter value along the element (should be greater than 0 and less than 1).
Return Value
ElementIdThe newly created analytical member id.

Exception | Condition |
---|---|
InvalidOperationException | Analytical member cannot be split. |

Analytical members that are not a line or an arc are not permitted. See CanSplit to determine if the analytical member is allowed to be split by this method.