IExternal |
Implement this method to get operations supported by the external server for a particular type of external resource.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- extensions ExternalResourceServerExtensions
- The class which owns sub-interface classes, each of which has methods related to a particular type of external resource.

Through this method, some specific operations for a paritcular type of external resource, such as Open(and Unload) and shared coordinates for Revit Link, can be set in a class ExternalResourceServerExtensions.
ExternalResourceServerExtensions is able to own sub-interface classes, each of which has methods related to a particular type of external resource.