AvailabilityClassName Property


External Commands Data Availability Class Name Property

The full class name for the class providing the entry point to decide availability of this menu item.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string AvailabilityClassName { get; set; }

Property Value

String
Exceptions
Exception Condition
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
This is the class implementing IExternalCommandAvailability interface.
See Also