AppearanceAssetId Property


Material Appearance Asset Id Property

The ElementId of the AppearanceAssetElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId AppearanceAssetId { get; set; }

Property Value

ElementId
The id of the AppearanceAssetElement, or InvalidElementId if the material does not have an associated appearance asset.
Exceptions
Exception Condition
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
This is the id to the element that contains visual material information used for rendering. In some cases where the material is created without setting up custom render appearance properties (for example, when the material is created via an import, or when it is created by the API), this property will be InvalidElementId. In that situation the standard material properties such as Color and Transparency will dictate the appearance of the material during rendering.
See Also