IExporterIFC Interface


IExporter IFC Interface

The interface used to implement a custom IFC exporter.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public interface IExporterIFC : IExternalServer

The IExporterIFC type exposes the following members.

Methods
Name Description
Public method ExportIFC The method that Revit will invoke to perform an export to IFC.
Public method GetDescription Implement this method to return a description of the server.
(Inherited from IExternalServer )
Public method GetName Implement this method to return the name of the server.
(Inherited from IExternalServer )
Public method GetServerId Implement this method to return the id of the server.
(Inherited from IExternalServer )
Public method GetServiceId Implement this method to return the id of the service.
(Inherited from IExternalServer )
Public method GetVendorId Implement this method to return the id of the vendor of the server.
(Inherited from IExternalServer )
Top
Remarks
Implement this interface and register an instance of the derived class with ExporterIFCRegistry.
See Also