Export Method (String, String, ViewSet, DWFXExportOptions)


Document Export(String, String, View Set, DWFXExport Options) Method

Exports the current view or a selection of views in DWFX format.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Export(
	string folder,
	string name,
	ViewSet views,
	DWFXExportOptions options
)

Parameters

folder String
Output folder, into which file(s) will be exported. The folder must exist.
name String
Either the name of a single file or a prefix for a set of files. If or empty, automatic naming will be used.
views ViewSet
Selection of views to be exported.
options DWFXExportOptions
Various options applicable to the DWFX format. If , all options will be set to their respective default values.

Return Value

Boolean
Function returns true only if all specified views are exported successfully. The function returns False if exporting of any view fails, even if some views might have been exported successfully.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input views is
ArgumentException Thrown when the input views is an empty ViewSet.
InvalidOperationException Thrown when the current document is not modifiable.
Remarks
All the views must be printable in order for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.
See Also