ElementRecord Class


Element Record Class

A record in the Revit database representing an element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ElementRecord

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementRecord : IDisposable

The ElementRecord type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property WorksetId Get Id of the workset which owns the element.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ElementRecord
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetBoundingBox Gets the bounding box of the element record.
Public method GetCategoryId Gets the category id of the element record.
Public method GetDesignOptionId Gets the design option id of the element record.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetId Gets the id of the element record.
Public method GetOwnerViewId Gets the element id of the owner view record.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method HasBoundingBox Determines whether this element record has a bounding box.
Public method IsAnElementType Identifies if the element record represents an ElementType.
Public method IsCurveDriven Identifies if the element is curve driven.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The record is used to extract basic information about an element before the element is fully expanded in memory.
See Also