Ribbon |
The base class of the RibbonItem event arguments which have UIApplication property.

System Object
System EventArgs
Autodesk.Revit.UI.Events RibbonItemEventArgs
Autodesk.Revit.UI.Events ComboBoxCurrentChangedEventArgs
Autodesk.Revit.UI.Events ComboBoxDropDownClosedEventArgs
Autodesk.Revit.UI.Events ComboBoxDropDownOpenedEventArgs
Autodesk.Revit.UI.Events TextBoxEnterPressedEventArgs
System EventArgs
Autodesk.Revit.UI.Events RibbonItemEventArgs
Autodesk.Revit.UI.Events ComboBoxCurrentChangedEventArgs
Autodesk.Revit.UI.Events ComboBoxDropDownClosedEventArgs
Autodesk.Revit.UI.Events ComboBoxDropDownOpenedEventArgs
Autodesk.Revit.UI.Events TextBoxEnterPressedEventArgs
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The RibbonItemEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | RibbonItemEventArgs | Initializes a new instance of the RibbonItemEventArgs class |

Name | Description | |
---|---|---|
![]() | Application | The current UIApplication. |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |