Reference Class


Reference Class

A stable reference to a geometric object in a Revit model.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Reference : APIObject

The Reference type exposes the following members.

Constructors
Name Description
Public method Reference Creates a Reference with the supplied element.
Top
Properties
Name Description
Public property ElementId The element id for this reference.
Public property ElementReferenceType The type of reference.
Public property GlobalPoint The position on which the reference is hit.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property LinkedElementId The id of the top-level element in the linked document that is referred to by this reference.
Public property UVPoint The UV parameters of the reference, if the reference contains a face.
Top
Methods
Name Description
Public method Contains Checks if given reference identifies part of object identified by this reference.
Public method Code example ConvertToStableRepresentation Converts the reference to a stable String representation.
Public method CreateLinkReference Creates a Reference from a Reference in an RVT Link.
Public method CreateReferenceInLink Creates a Reference in an RVT Link from a Reference in the RVT host file.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method EqualTo Checks if given reference is equal to this reference.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Static member Code example ParseFromStableRepresentation Converts a stable String representation of a reference to a Reference object.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also