GetItemFolders Method


Fabrication Configuration Get Item Folders Method

Gets a list of fabrication item folders in the fabrication item folder structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<FabricationItemFolder> GetItemFolders()

Return Value

IList FabricationItemFolder
Returns a list of fabrication item folders in the fabrication item folder structure.
Exceptions
Exception Condition
InvalidOperationException The current fabrication configuration is not connected and updated to source configuration. Reload and try again.
Remarks
To get the item folders, you may need to call ReloadConfiguration first.
See Also