GetReCapProject Method


Point Cloud Type Get Re Cap Project Method

This method provides a direct entry point to get access to an object from the ReCap SDK (ReCapWrapper.RCProject) from Revit. This object represents the point cloud from the RC file path stored in PointCloudType. The ReCap assembly AdskRcManaged.dll will need to be included into code using this method.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public RCProject GetReCapProject()

Return Value

RCProject
Exceptions
Exception Condition
FileAccessException The file or PointCloudEngine is not ReCap based.
InvalidOperationException Exception happens when ReCap loading the project.
Remarks
The coordinate system in RCProject is defined by Point Cloud. Please refer to ReCap SDK document for RCProject::getCoordinateSystem. If you need points converted to the modeling coordinate system in Revit, you can obtain the transformation matrix from PointCloudInstance GetTransform .
See Also