TriangulatedShellComponent Class


Triangulated Shell Component Class

This class represents a triangulated boundary component of a solid or a triangulated connected component of a shell.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TriangulatedShellComponent

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class TriangulatedShellComponent : IDisposable

The TriangulatedShellComponent type exposes the following members.

Properties
Name Description
Public property IsClosed True if and only if the triangulation represents a topologically closed shell (i.e., each edge is shared by two triangles).
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property TriangleCount The number of triangles in the triangulation.
Public property VertexCount The number of vertices in the triangulation.
Top
Methods
Name Description
Public method Clear Empties the contents of this TriangulatedShellComponent.
Public method Dispose Releases all resources used by the TriangulatedShellComponent
Public method GetTriangle Returns the triangle corresponding to the given index.
Public method GetVertex Returns the vertex with a given index.
Public method GetVertices Returns the vertices of the triangulation.
Top
Remarks
The triangulation is "topologically connected" in the following sense: if two triangles share an edge geometrically, then they share a single edge topologically (i.e., they share two vertices defining the geometrically shared edge).
See Also