GetReferenceByName Method


Family Instance Get Reference By Name Method

Gets the family instance reference corresponding to the named reference plane in the instance's family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Reference GetReferenceByName(
	string name
)

Parameters

name String
The name of the reference plane in the family.

Return Value

Reference
Returns the family instance reference corresponding to the named reference plane in the instance's family. Returns null if there is no reference plane with this name in the family, or if the plane exists but its "Is Reference" property is "Not a Reference", or if the input string is empty.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If there is a reference plane in the instance's family that has the given name, and the plane's "Is Reference" property is not "Not a Reference", there will be a corresponding reference in the family's instance. This function returns that reference.
See Also