BuiltInFailures.GeneralFailures Class


Built In Failures General Failures Class

Failures about GeneralFailures.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures GeneralFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class GeneralFailures

The BuiltInFailures GeneralFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotFixProblem Failed to fix problem. Action has to be cancelled.
Public property Static member CannotSetParameter Cant set parameter
Public property Static member CharactersNotAllowed Name cannot contain any of the following characters:\n[{}[]|;<>?`~]\nor any of the non-printable characters.
Public property Static member ContentDocTreeCorruption Problems with the Content Doc Tree structure - e.g. orphaned Content Docs, Families w/o docs, missing Owner Fam, what-not
Public property Static member ConvertingOldAxisToNormal This operation will convert the existing axis of revolution to a normal line.
Public property Static member CoreElemTestingError Core element testing error (internal).
Public property Static member DuplicateValue Elements have duplicate '[Value]' values.
Public property Static member EnterNonNegativeValue Enter a non-negative value.
Public property Static member EnterValidRealGreaterThan Enter a number greater than [Value].
Public property Static member EnterValueBetween Please enter a value between [Value] and [Value].
Public property Static member ErrorInFamilyResolved An error occurred in family "[Name]" and was automatically resolved. Please review changes made to the family.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
Public property Static member ErrorInSymbolFamilyResolved An error occurred in family "[Name]" and was automatically resolved, but may require review by the family creator.\nError Information:\n"[Text]"\nError Resolution: [Resolution]
Public property Static member ErrorResolved Error "[Text]" was automatically resolved by "[Resolution]"
Public property Static member FailedToOpenFile Failed to open file.
Public property Static member FailedToReadLine Failed to read line.
Public property Static member FamilySeparationTestingError Family separation testing error (internal).
Public property Static member GenericCorruption A generic error has occurred.
Public property Static member GenericError Error.
Public property Static member GenericErrorNone None.
Public property Static member GenericFatalError A fatal error has occurred. The application will be terminated. You will be given the opportunity to save recovery files for all of your changed projects.\tWould you like to save a recovery file for [Project Name]?
Public property Static member GenericNonFatalError A serious error has occurred. It is strongly recommended that you use Save As to save your work in a new file before continuing.
Public property Static member GenericWarning A generic error has occurred.
Public property Static member InaccuracyDetected A geometric inaccuracy was found in the element.
Public property Static member InternalProblemsParameter Parameter cannot be changed due to internal problems.
Public property Static member InvalidInput Invalid Input
Public property Static member InvalidInputWarn Invalid Input
Public property Static member InvalidOrderOfPhases Invalid order of phases: [Type Name] cannot be demolished before it was created.
Public property Static member InvalidValue Invalid value.
Public property Static member NameInUse The name "[Name]" is already in use.
Public property Static member NameIsEmpty Name is empty
Public property Static member NameNotUnique The name entered is already in use. Enter a unique name.
Public property Static member NoRelatedWarnings Document doesn't contain any warnings related to these elements.
Public property Static member ParameterValueNotInRange The value for [Parameter Name] must be between [Value] and [Value].
Public property Static member ParameterValuesConflict The value for [Parameter Name] must be at least [Value] below the value for [Parameter Name].
Public property Static member SeriousElementReferenceCorruption Element references are seriously corrupt.
Public property Static member TransactionFailed [Description]
Public property Static member TransactionFailedWarn [Description]
Public property Static member UnresolvableErrorInFamily An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
Public property Static member UnresolvableErrorInFamilyWarn An error occurred in family "[Name]" that cannot be automatically resolved.\nError Information:\n"[Text]"
Public property Static member UnspecifiedError Revit has experienced an unexpected error. The operation has been cancelled to protect your project from corruption.
Public property Static member ValueOutOfRange Value is out of range ! Please enter a number between [Value] and [Value].
Public property Static member WarningInFamilyDismissed A warning in family "[Name]" was dismissed. Please review warning information to determine if any changes are necessary\nWarning Information:\n"[Text]"
Top
See Also