RebarShapeConstraint180DegreeBendArcLength Class


Rebar Shape Constraint 180Degree Bend Arc Length Class

A constraint which can be applied to a RebarShapeSegment, and causes the segment to be replaced with a 180-degree arc. The associated parameter drives the arc length.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraint180DegreeBendArcLength

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraint180DegreeBendArcLength : RebarShapeConstraint

The RebarShapeConstraint180DegreeBendArcLength type exposes the following members.

Constructors
Name Description
Public method RebarShapeConstraint180DegreeBendArcLength Create a 180-degree bend constraint driven by arc length.
Top
Properties
Name Description
Top
Methods
Name Description
Top
See Also