PlaceAsTap Method


Fabrication Part Place As Tap Method

Places the part by its connector to a specific position on the straight part at the specified distance from the host part connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void PlaceAsTap(
	Document document,
	Connector tapPartConnector,
	Connector hostPartConnector,
	double distance,
	double axisRotation,
	double secondaryAxisRotation
)

Parameters

document Document
The document.
tapPartConnector Connector
The connector of the part to place.
hostPartConnector Connector
The connector of host part.
distance Double
The distance to host part connector where to place the part.
axisRotation Double
The axis rotation in radians.
secondaryAxisRotation Double
The secondary axis rotation in radians.
Exceptions
Exception Condition
ArgumentException It is not a valid part to place as tap. -or- Tap should be placed on straight part. -or- The distance is out of range. -or- For rectangular and oval parts the axis rotation must be a multiple of PI/2. -or- Invalid tap for host's profile type. -or- The fabrication part is connected.
ArgumentNullException A non-optional argument was null
InvalidOperationException tap is not connected by its primary connector.
[!:Autodesk::Revit::Exceptions::InvalidOpertationException] tap does not fit on the host.
Remarks
Tap cannot be placed if it is already connected.
See Also