ShapeImporter Class


Shape Importer Class

A utility class that supports conversion of geometry stored in an external format into a Revit geometry objects.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ShapeImporter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ShapeImporter : IDisposable

The ShapeImporter type exposes the following members.

Constructors
Name Description
Public method ShapeImporter Default constructor. Initializes an instance of ShapeImporter that will automatically recognize the file format from its extension (ShapeImporterSourceFormat.Auto).
Top
Properties
Name Description
Public property DefaultLengthUnit The length unit to be used if not specified when the input is a unitless SAT file.
Public property InputFormat The format of the incoming data.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Convert Converts the geometry stored in the external format into a collection of Revit geometry objects.
Public method Dispose Releases all resources used by the ShapeImporter
Public method Static member IsServiceAvailable Checks whether the data conversion service is available.
Public method SetDefaultLengthUnit Sets the length unit to be used when the input is a unitless SAT file.
Top
Remarks
See ShapeImporterSourceFormat for the list of supported formats.
See Also