CompareAssemblyInstances Method


Assembly Instance Compare Assembly Instances Method

Compares two assembly instances and returns a result with details about the differences

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static AssemblyDifference CompareAssemblyInstances(
	AssemblyInstance instance1,
	AssemblyInstance instance2
)

Parameters

instance1 AssemblyInstance
The first assembly instance to compare
instance2 AssemblyInstance
the second assembly instance to compare

Return Value

AssemblyDifference
An object describing the difference between the two instances
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Only the first found difference is returned. If the instances are identical, AssemblyDifferenceNone will be returned.
See Also