TransmissionData Class


Transmission Data Class

A class representing information on all external file references in a document.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB TransmissionData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class TransmissionData : IDisposable

The TransmissionData type exposes the following members.

Constructors
Name Description
Public method TransmissionData Constructs a TransmissionData from another TransmissionData
Top
Properties
Name Description
Public property IsTransmitted Determines whether this file has been transmitted or not.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property UserData A string which users can store notes in.
Public property Version The format version for TransmissionData
Top
Methods
Name Description
Public method Dispose Releases all resources used by the TransmissionData
Public method Static member DocumentIsNotTransmitted Determines whether the document at a given file location is not transmitted.
Public method GetAllExternalFileReferenceIds Gets the ids of all ExternalFileReferences.
Public method GetDesiredReferenceData Gets the ExternalFileReference representing path and load status information to be used the next time this TransmissionData's document is loaded.
Public method GetLastSavedReferenceData Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.
Public method Static member IsDocumentTransmitted Determines whether the document at a given file location is transmitted.
Public method Static member ReadTransmissionData Reads the TransmissionData associated with the file at the given location.
Public method SetDesiredReferenceData Sets the ExternalFileReference information which Revit should use the next time it opens the document which this TransmissionData belongs to.
Public method Static member WriteTransmissionData Writes the given TransmissionData into the Revit file at the given location.
Top
Remarks

TransmissionData stores information on both the previous state and requested state of an external file reference. This means that it stores the load state and path of the reference from the most recent time this TransmissionData's document was opened. It also stores load state and path information for what Revit should do the next time the document is opened.

As such, TransmissionData can be used to perform operations on external file references without having to open the entire associated Revit document. The methods ReadTransmissionData and WriteTransmissionData can be used to obtain information about external references, or to change that information. For example, calling WriteTransmissionData with a TransmissionData object which has had all references set to LinkedFileStatus.Unloaded would cause no references to be loaded upon next opening the document.

TransmissionData cannot add or remove references to external files. If, on file open, Revit discovers information in the TransmissionData which does not correspond to an existing external file reference, the information will be ignored on file load.

The TransmissionData for a document does not contain information about references which come from external servers. TransmissionData only contains references to local files or Revit links on Revit Server. TransmissionData cannot be used to change a reference from a local file reference to an external server reference.

Note that TransmissionData objects must be set to "transmitted" for the requested reference data to be meaningful. Revit ignores the TransmissionData for non-transmitted files. Marking a file as transmitted has other effects - workshared files are opened as detached from the central model, and creation of new local files is prohibited, until the file is in its final location and the file has been marked as no longer transmitted.

See Also