TransmittedModelOptions Enumeration


Transmitted Model Options Enumeration

Enum giving desired behavior when opening or saving a transmitted workshared model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum TransmittedModelOptions
Members
Member name Value Description
CancelOperation 2 Cancel the save or load operation.
KeepAsTransmitted 1 The model will remain marked as transmitted; users will not be able to create locals until it is saved as a new central.
SaveAsNewCentral 0 The model should be saved as a new central. (On open, it will be saved as a new central in its current location. On save, it will be saved as central but the user can choose a location.)
See Also