Structural |
Defines parameters for L profile structural section.

System Object
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionColdFormed
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralLA
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionLProfile
Autodesk.Revit.DB.Structure.StructuralSections StructuralSection
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionRectangular
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionColdFormed
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionGeneralLA
Autodesk.Revit.DB.Structure.StructuralSections StructuralSectionLProfile
Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The StructuralSectionLProfile type exposes the following members.

Name | Description | |
---|---|---|
![]() | StructuralSectionLProfile | Creates a new instance of Structural Section L Profile shape with the associated set of parameters, used to attach to structural element. |

Name | Description | |
---|---|---|
![]() | AnalysisParams | Common set of parameters for structural analysis. (Inherited from StructuralSection ) |
![]() | CentroidHorizontal | Distance from centroid to the left extremites along horizontal axis. (Inherited from StructuralSectionRectangular ) |
![]() | CentroidVertical | Distance from centroid to the upper extremites along vertical axis. (Inherited from StructuralSectionRectangular ) |
![]() | ElasticModulusStrongAxis | Elastic section modulus about main strong axis for calculation of bending stresses. (Inherited from StructuralSection ) |
![]() | ElasticModulusWeakAxis | Elastic section modulus about main weak axis for calculation of bending stresses. (Inherited from StructuralSection ) |
![]() | Height | Section height, depth. (Inherited from StructuralSectionRectangular ) |
![]() | InnerFillet | Inner Fillet - Corner fillet inner radius. (Inherited from StructuralSectionColdFormed ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from StructuralSection ) |
![]() | LipLength | Lip segment length. (Inherited from StructuralSectionGeneralLA ) |
![]() | MomentOfInertiaStrongAxis | Moment of Inertia about main strong axis (I). (Inherited from StructuralSection ) |
![]() | MomentOfInertiaWeakAxis | Moment of Inertia about main weak axis (I). (Inherited from StructuralSection ) |
![]() | NameKey | Name Key (Inherited from StructuralSectionRectangular ) |
![]() | NominalWeight | Unit weight (not mass) per unit length, for self-weight calculation or quantity survey. (Inherited from StructuralSection ) |
![]() | Perimeter | Painting surface of the unit length. (Inherited from StructuralSection ) |
![]() | PlasticModulusStrongAxis | Plastic section modulus in bending about main strong axis (Z, Wpl). (Inherited from StructuralSection ) |
![]() | PlasticModulusWeakAxis | Plastic section modulus in bending about main weak axis. (Inherited from StructuralSection ) |
![]() | PrincipalAxesAngle | Rotation angle between the principal axes and cross section reference planes. (Inherited from StructuralSection ) |
![]() | SectionArea | Cross section area. (Inherited from StructuralSection ) |
![]() | SectionNameKey | A parameter in structural families which allows for family type identification. This will be used for data mapping during model exchange with another program, namely Advance Steel. (Inherited from StructuralSection ) |
![]() | ShearAreaStrongAxis | Shear area (reduced extreme shear stress coefficient) in the direction of strong axis (Wq). (Inherited from StructuralSection ) |
![]() | ShearAreaWeakAxis | Shear area (reduced extreme shear stress coefficient) in the direction of weak axis (Wq). (Inherited from StructuralSection ) |
![]() | StructuralSectionGeneralShape | The general type of structural section shape. (Inherited from StructuralSection ) |
![]() | StructuralSectionShape | The type of structural section shape. (Inherited from StructuralSection ) |
![]() | StructuralSectionShapeName | A human readable string representing the structural section shape. (Inherited from StructuralSection ) |
![]() | TorsionalModulus | Section modulus for calculations of torsion stresses (Ct). (Inherited from StructuralSection ) |
![]() | TorsionalMomentOfInertia | Torsional Moment of inertia (J, IT, K), for calculation of torsional deformation (Inherited from StructuralSection ) |
![]() | WallDesignThickness | Represents wall design thickness of rectangle. (Inherited from StructuralSectionColdFormed ) |
![]() | WallNominalThickness | Represents wall nominal thickness of rectangle. (Inherited from StructuralSectionColdFormed ) |
![]() | WarpingConstant | Warping constant (Cw, Iomega, H). (Inherited from StructuralSection ) |
![]() | Width | Section width. (Inherited from StructuralSectionRectangular ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from StructuralSection ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetBoundarySize | Returns size of the section boundary. (Inherited from StructuralSection ) |
![]() | GetEnumerator | (Inherited from StructuralSection ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |