Create Method (Curve)


BRep Builder Edge Geometry Create(Curve) Method

Construct BRepBuilderEdgeGeometry based on any Revit Curve, including Line and Arc. The curve will be simplified if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static BRepBuilderEdgeGeometry Create(
	Curve curve
)

Parameters

curve Curve
The 3D curve for this edge. This BRepBuilderEdgeGeometry stores a copy of the input curve.

Return Value

BRepBuilderEdgeGeometry
Exceptions
Exception Condition
ArgumentException The input curve is not bound. -or- The curve is degenerate (its length is too close to zero). -or- The endpoints of the curve are close enough that Revit considers it a closed curve.
ArgumentNullException A non-optional argument was null
See Also